It is very rare upgrades of Debian stable break functionality. It happened recently with asterisk, so my PBX was out of service. Due to bug #688053 I had to rollback the asterisk packages to restore service. This is how I proceeded, by just installing the previous version from the local filesystem.

dpkg -i /var/cache/apt/archives/asterisk_1%3a1.6.2.9-2+squeeze5_amd64.deb /var/cache/apt/archives/asterisk-config_1%3a1.6.2.9-2+squeeze5_all.deb /var/cache/apt/archives/asterisk-doc_1%3a1.6.2.9-2+squeeze5_all.deb dpkg: warning: downgrading asterisk from 1:1.6.2.9-2+squeeze7 to 1:1.6.2.9-2+squeeze5. (Reading database ... 55833 files and directories currently installed.) Preparing to replace asterisk 1:1.6.2.9-2+squeeze7 (using .../asterisk_1%3a1.6.2.9-2+squeeze5_amd64.deb) ... Stopping Asterisk PBX: asterisk. Unpacking replacement asterisk ... dpkg: warning: downgrading asterisk-config from 1:1.6.2.9-2+squeeze7 to 1:1.6.2.9-2+squeeze5. Preparing to replace asterisk-config 1:1.6.2.9-2+squeeze7 (using .../asterisk-config_1%3a1.6.2.9-2+squeeze5_all.deb) ... Unpacking replacement asterisk-config ... dpkg: warning: downgrading asterisk-doc from 1:1.6.2.9-2+squeeze7 to 1:1.6.2.9-2+squeeze5. Preparing to replace asterisk-doc 1:1.6.2.9-2+squeeze7 (using .../asterisk-doc_1%3a1.6.2.9-2+squeeze5_all.deb) ... Unpacking replacement asterisk-doc ... Setting up asterisk-config (1:1.6.2.9-2+squeeze5) ... Setting up asterisk-doc (1:1.6.2.9-2+squeeze5) ... Setting up asterisk (1:1.6.2.9-2+squeeze5) ... Starting Asterisk PBX: asterisk. Processing triggers for man-db ...